Hack, Slash, Loot, Chat
 
 
Post a Reply Post a Reply  
 
 
How to play on Linux ? There are 19 replies
Original Message posted by Xnala on 07/02/2012 at 2:07:31PM
I got a segmentation fault when I run HackSlashLoot... I think I need a tutorial. Thx.
 
 Replies To This Post:
 
David Williamson
Moderator
on 23/09/2012 at 4:33:53PM
Total Posts: 2
I can't replicate this. If you're up for a little testing then could you email me contact@gooeyblob.com and I'll send you some files to try tomorrow.
 
fci525
on 23/09/2012 at 2:26:16AM
Total Posts: 0
I've tried all of that, still no luck. Let me know if there's anything else I can provide to help troubleshoot this.
 
David Williamson
Moderator
on 22/09/2012 at 11:52:13PM
Total Posts: 2
First thing to try is to delete the contents of the data folder, and trying to run it again. If that doesn't help then make sure you have the the 32bit libs and the file is marked as 'run as executable', or whatever your distro calls it. If all hat fails then I'll admit I'm stumped without more info. I'll install arch Linux and see what I can do.
 
fci525
on 22/09/2012 at 7:09:23PM
Total Posts: 0
I realize this is several months old, but I'm having the same problem (with the demo). I'm running arch linux x86_64. I tried out the demo on a windows machine and enjoyed it, but I'm wary of buying it for my own computer until I'm confident it will run.

When I run it, a window appears for a fraction of a second, and the only output in my terminal is "Segmentation fault". The permissions are correctly set, and it manages to create ~/.HackSlashLoot/Data/linuxaudio.txt.
 
Peter Badger
on 10/04/2012 at 10:59:48PM
Total Posts: 0
I was segfaulting on start up at one point because I had a full disk.  I think your file operation checking is insufficient.

It tried to open a file, failed, and then tried to access the file.  It should have caught the failure and quit, possibly printing or making a dialog saying the disk is full or at least the file could not be opened.
 
David Williamson
Moderator
on 05/04/2012 at 9:02:40AM
Total Posts: 2
Some Linux users have had to check 'allow execute as program' from the files properties - Right click>Properties>Permissions>Execute as program. I'm not sure why this affects some people and not others.
 
mangue
on 05/04/2012 at 4:58:33AM
Total Posts: 0
Same here. Can't run on linux. Just found out it and thought it to be very cool to play this old school game in my linux laptop. Sad it doesn't work.

Ubuntu 11.10 64 bits.
Radeon Graphics

I tryied with the zip file from indie royal and from desura. No go.

Error is: "File or Directory not found"

The hidden directory in home folder is not even created.

I have 32 bit libs installed.

ldd says "This is not a dynamic linked executable"

I manually created the directory, same error.
 
scrapbrain
on 25/03/2012 at 11:04:35PM
Total Posts: 0
Deleting files into directory does not work... I still get segfault... :(
I don't know if it helps: I tried to execute http://gooeyblob.com/temp/hsl_linux_test.zip and then ./HackSlashLoot "listaudio". The output is:

$./HackSlashLoot "listaudio"
"FreeAudio"
"FreeAudio OpenSound System"
"Null"

then I tried ./HackSlashLoot "Driver Name" and I get segmentation fault...
Into directory .HackSlashLoot/Data/ there is only a file: linuxaudio.txt
Edit: Segmentation Fault with "FreeAudio", "FreeAudio OpenSound System" and "Null".
 
David Williamson
Moderator
on 25/03/2012 at 12:10:11AM
Total Posts: 2
This could be difficult to track down as I'm not able to replicate it. The game obviously starts as it creates the default files, but something after that causes it to seg fault. One thing you could try is to delete the files inside the ~/.HackLootSlash/Data/ folder. It's a long shot, but for now it's the best I've got. I'll keep looking into it, but until I get some kind of clue as to what's happening then I'm not hopeful. Sorry it's not better news.

The game also works through Wine, or other VMs, but I know that's not ideal.
 
scrapbrain
on 24/03/2012 at 8:32:49PM
Total Posts: 0
Hello! I was trying to play the demo, but i get a segmentation fault when I run the executable...
I'm on a Gnu/Linux Fedora 16 x86_64. 

I will post here some news about my OS:

$uname -a
Linux kraken 3.2.7-1.fc16.x86_64 #1 SMP Tue Feb 21 01:40:47 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


and here some info about my machine:
Processor: Intel Core Duo @2.00 GHz x2 (CPU P7350)
Memory: 3,9GB
Graphic: GeForce 9600M GT/PCI/SSE2

As audio drivers my system has:

# yum info alsa-plugins-pulseaudio
Plugin abilitati:langpacks, presto, refresh-packagekit
Pacchetti installati
Nome         : alsa-plugins-pulseaudio
Arch         : i686
Versione     : 1.0.25
Rilascio     : 3.fc16
Dimensione   : 94 k
Repo         : installed
Dal repo     : updates
Sommario     : Alsa to PulseAudio backend
URL          : http://www.alsa-project.org/
Licenza      : LGPLv2+
Descrizione  : This plugin allows any program that uses the ALSA API to access a PulseAudio
             : sound daemon. In other words, native ALSA applications can play and record
             : sound across a network. There are two plugins in the suite, one for PCM and
             : one for mixer control.

Nome         : alsa-plugins-pulseaudio
Arch         : x86_64
Versione     : 1.0.25
Rilascio     : 3.fc16
Dimensione   : 101 k
Repo         : installed
Dal repo     : updates
Sommario     : Alsa to PulseAudio backend
URL          : http://www.alsa-project.org/
Licenza      : LGPLv2+
Descrizione  : This plugin allows any program that uses the ALSA API to access a PulseAudio
             : sound daemon. In other words, native ALSA applications can play and record
             : sound across a network. There are two plugins in the suite, one for PCM and
             : one for mixer control.


As graphic drivers my system has:

# yum info installed akmod-nvidia.x86_64
Plugin abilitati:langpacks, presto, refresh-packagekit
Pacchetti installati
Nome         : akmod-nvidia
Arch         : x86_64
Epoch        : 1
Versione     : 290.10
Rilascio     : 1.fc16.4
Dimensione   : 8.7 M
Repo         : installed
Dal repo     : rpmfusion-nonfree-updates
Sommario     : Akmod package for nvidia kernel module(s)
URL          : http://www.nvidia.com/
Licenza      : Redistributable, no modification permitted
Descrizione  : This package provides the akmod package for the nvidia kernel modules.


The ~/.HackLootSlash/Data/ directory is created and there are files inside, so I don't think it is a directory creation problem... 
Sorry for my bad english, I'm italian.

Edit: I'm also using GNOME 3.2.1
 
runequester
on 12/02/2012 at 6:00:08AM
Total Posts: 0
okay, that did the trick, thanks!
 
David Williamson
Moderator
on 11/02/2012 at 2:06:45PM
Total Posts: 2
What is happening is that the folder ~/.HackSlashLoot/Data is failing during creation. If you create it yourself then the current version should work. I've just got to do a little testing before uplaoding the fix.
 
runequester
on 11/02/2012 at 1:12:04PM
Total Posts: 0
awesome, can't wait to play :)
 
David Williamson
Moderator
on 10/02/2012 at 11:30:01PM
Total Posts: 2
Ok I've got a handle on the seg fault. Expect an update next week sometime.
 
David Williamson
Moderator
on 09/02/2012 at 11:52:59AM
Total Posts: 2
I'm currently installing as many flavours of Linux on as many machines as I can get my hands on. Hopefully I can get to the bottom of this. Please bear with me.
 
runequester
on 09/02/2012 at 5:54:01AM
Total Posts: 0
Segfaults for me as well on Kubuntu 11.10 64 bit
 
RANDON
on 08/02/2012 at 8:08:51PM
Total Posts: 0
I also got a 'segmentation fault' message on my linux.

Ubuntu 11.10 32bit
 
David Williamson
Moderator
on 08/02/2012 at 7:52:27PM
Total Posts: 2
It works on my test machine. Is this the demo or the full game? Which Linux distros are we talking about?
 
RedArremer
on 08/02/2012 at 7:37:36PM
Total Posts: 0
I also need help. And I speak French. So please be explicit.