Hack, Slash, Loot, Chat
 
 
Post a Reply Post a Reply  
 
 
Running on Linux x86_64 There are 2 replies
Original Message posted by SyBorg on 07/06/2012 at 4:16:42PM
Hello HSLers,

first of all thanks to David (also my son's name :) ) for his quick reply to my request

This is mostly a memorandum for what I did.

I was trying to run this game in my office PC (heh) and it was complaining with this error:
error while loading shared libraries: libXxf86vm.so.1: cannot open shared object file: No such file or directory

I'm not a Linux guru, so after some googling I found what was missing:
ldd /usr/local/bin/HackSlashLoot
[...]
libXxf86vm.so.1 => not found
libGLU.so.1 => not found
[...]

I'm running on a 64bit system as I said:
uname -rv
3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012

So I crossed fingers and installed the missing parts (some of them were already installed, I suspect because of Skype dependencies):
sudo apt-get install libglu1-mesa:i386 libxxf86vm1:i386

Game ran but audio was missing, but this did the trick:
sudo apt-get install pulseaudio-utils:i386
padsp /usr/local/bin/HackSlashLoot

I'd like to hear from others who found similar issues, did I do everything good or should I be ready to reinstall the office environment?

Happy looting everyone
 
 Replies To This Post:
 
BlaXpirit
on 28/02/2014 at 11:08:49PM
Total Posts: 0
What worked for me on Arch Linux 64bit (the OpenAL parts make sound work as well):

pacman -S lib32-glu lib32-libtxc_dxtn lib32-openal
pacman -S lib32-intel-dri # this is for Intel graphics, you may need something else here
./HackSlashLoot "OpenAL"
 
acidictinomen
on 09/07/2012 at 7:20:07PM
Total Posts: 0
I was having the same problem on my machine. A quick look at your post though gave me all the info I needed. Thanks a ton!